Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 15 von 19
WoW auf OS X El Capitan startet nicht.
von 5 Sternen, basierend auf 0 abgegebenen Stimmen.
  1. #1
    Neuling Avatar von DeNico
    Registriert seit
    21.11.2015
    Beiträge
    2
    Mag ich
    0
    Wurde 0 mal in 0 Beiträgen
    positiv bewertet.

    Frage WoW auf OS X El Capitan startet nicht

    Hi alle miteinander,
    ich wollte mir vor einigen Tagen mal wieder Classic WoW installieren und habe mir deshalb den Client runtergeladen. Wenn ich den Client von der classic-wow.org Seite für OS X benutze erhalte ich immer die Fehlermeldung

    "Das Programm „World of Warcraft“ kann nicht geöffnet werden."

    Dann habe ich mir einen anderen Client für 1.12.1 runtergeladen. Bei dem wird der Bildschirm schwarz und es scheint, als würde das Spiel jetzt starten. Jedoch kommt dann nach fünf Sekunden etwa der Fehler, dass WoW unerwartet beendet wurde.

    Hat jemand da vielleicht eine Idee was ich da machen kann?

    Hier noch der Fehler den ich bekomme wenn es starten will:


    Code:
    Process:               World of Warcraft [47728]
    Path:                  /Users/USER/Downloads/*/WoW Classic.app/Contents/MacOS/World of Warcraft
    Identifier:            com.blizzard.worldofwarcraft
    Version:               1.12.1 (1.12.1)
    Code Type:             X86 (Native)
    Parent Process:        ??? [1]
    Responsible:           World of Warcraft [47728]
    User ID:               501
    
    
    Date/Time:             2015-12-21 15:34:19.222 +0100
    OS Version:            Mac OS X 10.11.1 (15B42)
    Report Version:        11
    Anonymous UUID:        31F582F4-11D7-0FE4-B243-78F623432A3A
    
    
    Sleep/Wake UUID:       9385CDEE-2DB4-49B4-9046-F53712DD56D3
    
    
    Time Awake Since Boot: 770000 seconds
    Time Since Wake:       520 seconds
    
    
    System Integrity Protection: enabled
    
    
    Crashed Thread:        0  Dispatch queue: com.apple.main-thread
    
    
    Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000010
    Exception Note:        EXC_CORPSE_NOTIFY
    
    
    VM Regions Near 0x10:
    --> 
        __TEXT                 0000000000001000-0000000000693000 [ 6728K] r-x/rwx SM=COW  /Users/USER/Downloads/*/WoW Classic.app/Contents/MacOS/World of Warcraft
    
    
    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
    0   libobjc.A.dylib                   0x9244c161 (anonymous namespace)::AutoreleasePoolPage::pop(void*) + 409
    1   com.apple.CoreFoundation          0x968b4aff _CFAutoreleasePoolPop + 47
    2   com.apple.HIToolbox               0x9b0b1200 HIPopAutoreleasePool + 18
    3   com.apple.HIToolbox               0x9b218cdd ModalDialog + 448
    4   com.apple.HIToolbox               0x9b2213e1 RunStandardAlert + 750
    5   com.blizzard.worldofwarcraft      0x00011253 0x1000 + 66131
    6   com.blizzard.worldofwarcraft      0x0001c3bd 0x1000 + 111549
    7   com.blizzard.worldofwarcraft      0x0000e277 0x1000 + 53879
    8   com.blizzard.worldofwarcraft      0x0000f174 0x1000 + 57716
    9   com.blizzard.worldofwarcraft      0x00004085 0x1000 + 12421
    10  com.apple.HIToolbox               0x9b0cf68b _InvokeEventHandlerUPP(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*, long (*)(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*)) + 36
    11  com.apple.HIToolbox               0x9b0779a0 DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1832
    12  com.apple.HIToolbox               0x9b076bb4 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 402
    13  com.apple.HIToolbox               0x9b076a1a SendEventToEventTargetWithOptions + 40
    14  com.apple.HIToolbox               0x9b0b0212 ToolboxEventDispatcherHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 1994
    15  com.apple.HIToolbox               0x9b077def DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 2935
    16  com.apple.HIToolbox               0x9b076bb4 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 402
    17  com.apple.HIToolbox               0x9b089f6d SendEventToEventTarget + 34
    18  com.apple.HIToolbox               0x9b22709e ToolboxEventDispatcher + 82
    19  com.apple.HIToolbox               0x9b226f5f RunApplicationEventLoop + 240
    20  com.blizzard.worldofwarcraft      0x000041b6 0x1000 + 12726
    21  com.blizzard.worldofwarcraft      0x00003172 0x1000 + 8562
    22  com.blizzard.worldofwarcraft      0x0000308d 0x1000 + 8333
    
    
    Thread 1:
    0   libsystem_kernel.dylib            0x91009e16 __workq_kernreturn + 10
    1   libsystem_pthread.dylib           0x927c335f _pthread_wqthread + 1289
    2   libsystem_pthread.dylib           0x927c0f82 start_wqthread + 34
    
    
    Thread 2:: Dispatch queue: com.apple.libdispatch-manager
    0   libsystem_kernel.dylib            0x9100a8b2 kevent_qos + 10
    1   libdispatch.dylib                 0x90ca6792 _dispatch_mgr_invoke + 234
    2   libdispatch.dylib                 0x90ca6366 _dispatch_mgr_thread + 52
    
    
    Thread 3:
    0   libsystem_kernel.dylib            0x91009e16 __workq_kernreturn + 10
    1   libsystem_pthread.dylib           0x927c335f _pthread_wqthread + 1289
    2   libsystem_pthread.dylib           0x927c0f82 start_wqthread + 34
    
    
    Thread 4:
    0   libsystem_kernel.dylib            0x91009e16 __workq_kernreturn + 10
    1   libsystem_pthread.dylib           0x927c335f _pthread_wqthread + 1289
    2   libsystem_pthread.dylib           0x927c0f82 start_wqthread + 34
    
    
    Thread 5:
    0   libsystem_kernel.dylib            0x91009e16 __workq_kernreturn + 10
    1   libsystem_pthread.dylib           0x927c335f _pthread_wqthread + 1289
    2   libsystem_pthread.dylib           0x927c0f82 start_wqthread + 34
    
    
    Thread 6:
    
    
    Thread 0 crashed with X86 Thread State (32-bit):
      eax: 0x01808028  ebx: 0x00000000  ecx: 0x01808028  edx: 0x96875a9e
      edi: 0x9244bfdf  esi: 0x01808000  ebp: 0xbfffe978  esp: 0xbfffe740
       ss: 0x00000023  efl: 0x00010246  eip: 0x9244c161   cs: 0x0000001b
       ds: 0x00000023   es: 0x00000023   fs: 0x00000000   gs: 0x0000000f
      cr2: 0x00000010
      
    Logical CPU:     3
    Error Code:      0x00000004
    Trap Number:     14
    
    
    
    
    Binary Images:
        0x1000 -   0x692fd7 +com.blizzard.worldofwarcraft (1.12.1 - 1.12.1) /Users/USER/Downloads/*/WoW Classic.app/Contents/MacOS/World of Warcraft
     0x7359000 -  0x7359ffd +cl_kernels (???) <25EC0E2A-535B-40B2-B820-AB07E6459950> cl_kernels
     0x9000000 -  0x9582fff  com.apple.driver.AppleIntelBDWGraphicsGLDriver (10.10.18 - 10.1.0) <7784E127-614C-3876-9297-7361819F685A> /System/Library/Extensions/AppleIntelBDWGraphicsGLDriver.bundle/Contents/MacOS/AppleIntelBDWGraphicsGLDriver
    0x8fe4c000 - 0x8fe805bf  dyld (360.17) <E08B9CA8-D557-32D5-8DDD-E0B563900367> /usr/lib/dyld
    0x90010000 - 0x90019fff  libcopyfile.dylib (127) <C1D5D894-E71C-3E75-9639-82C846482A84> /usr/lib/system/libcopyfile.dylib
    0x9001a000 - 0x90023fff  com.apple.icloud.FindMyDevice (1.0 - 1) <FCEB3A69-A95A-3DE7-9240-8C818B332404> /System/Library/PrivateFrameworks/FindMyDevice.framework/Versions/A/FindMyDevice
    0x90024000 - 0x900ccff7  libCoreStorage.dylib (517) <3C43CB59-D386-3C5B-A0FC-B09BE932E1D7> /usr/lib/libCoreStorage.dylib
    0x900cd000 - 0x90226ff7  libBLAS.dylib (1159) <3F8CE2C9-FEEA-3611-BCE9-7887F9257C6E> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
    0x90227000 - 0x9023eff7  libmarisa.dylib (4) <B75FD855-AFE1-3F8F-A9D4-AA2A2B268B43> /usr/lib/libmarisa.dylib
    0x9023f000 - 0x9032afeb  libvMisc.dylib (563.4) <A010C853-F206-30EE-8993-59D5DDC7BA46> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libvMisc.dylib
    0x9032b000 - 0x904a4ff7  com.apple.audio.toolbox.AudioToolbox (1.13 - 1.13) <6AAAE45C-1AD8-38FE-AA30-317B9CAE02C3> /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox
    0x904ab000 - 0x904bcfff  libsystem_trace.dylib (200) <FEC2FA0C-7B2B-3735-87AB-D97A5F4D56FA> /usr/lib/system/libsystem_trace.dylib
    0x904bd000 - 0x90520fff  com.apple.CoreServices.OSServices (728.4 - 728.4) <0BF14CBE-0048-3D3D-86AB-322682D7A846> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServices.framework/Versions/A/OSServices
    0x90521000 - 0x90521fff  libunc.dylib (29) <6C251ECD-0449-384F-A5E3-D277C8DD9E13> /usr/lib/system/libunc.dylib
    
    ...(musste ich kürzen da es sonst zu lang zum posten ist)...
    
    
    External Modification Summary:
      Calls made by other processes targeting this process:
        task_for_pid: 1
        thread_create: 0
        thread_set_state: 0
      Calls made by this process:
        task_for_pid: 0
        thread_create: 0
        thread_set_state: 0
      Calls made by all processes on this machine:
        task_for_pid: 594762
        thread_create: 0
        thread_set_state: 0
    
    
    VM Region Summary:
    ReadOnly portion of Libraries: Total=186.2M resident=0K(0%) swapped_out_or_unallocated=186.2M(100%)
    Writable regions: Total=165.6M written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=165.6M(100%)
     
                                    VIRTUAL   REGION 
    REGION TYPE                        SIZE    COUNT (non-coalesced) 
    ===========                     =======  ======= 
    ATS (font support)                32.2M        4 
    Accelerate.framework               128K        2 
    Activity Tracing                  2048K        2 
    CG backing stores                 1436K        4 
    CG image                            24K        3 
    CG shared images                   368K       11 
    CoreUI image data                  192K        6 
    CoreUI image file                  192K        4 
    Kernel Alloc Once                    4K        2 
    MALLOC                            96.3M       42 
    MALLOC guard page                   48K       10 
    Memory Tag 242                      12K        2 
    Memory Tag 249                     156K        2 
    OpenCL                               8K        2 
    Process Corpse Info               2048K        2 
    Stack                             10.1M        7 
    Stack Guard                       56.0M        7 
    VM_ALLOCATE                        124K       16 
    __DATA                            15.1M      213 
    __GLSLBUILTINS                    2588K        2 
    __IMAGE                            528K        2 
    __IMPORT                            12K        2 
    __LINKEDIT                        50.8M        6 
    __OBJC                            2436K       59 
    __TEXT                           135.4M      221 
    __UNICODE                          552K        2 
    mapped file                      176.5M      145 
    shared memory                     16.3M        8 
    ===========                     =======  ======= 
    TOTAL                            601.2M      760 
    
    
    Model: MacBookPro12,1, BootROM MBP121.0167.B14, 2 processors, Intel Core i5, 2,7 GHz, 8 GB, SMC 2.28f7
    Graphics: Intel Iris Graphics 6100, Intel Iris Graphics 6100, Built-In
    Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1867 MHz, 0x80CE, 0x4B3445364533303445452D45474346000000
    Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1867 MHz, 0x80CE, 0x4B3445364533303445452D45474346000000
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x133), Broadcom BCM43xx 1.0 (7.21.94.29.1a4)
    Bluetooth: Version 4.4.2f1 16391, 3 services, 27 devices, 1 incoming serial ports
    Network Service: Wi-Fi, AirPort, en0
    Serial ATA Device: APPLE SSD SM0256G, 251 GB
    USB Device: USB 3.0 Bus
    USB Device: Bluetooth USB Host Controller
    Thunderbolt Bus: MacBook Pro, Apple Inc., 27.1

  2. #2
    Neuling Avatar von Kylian
    Registriert seit
    04.05.2012
    Beiträge
    7
    Mag ich
    0
    Wurde 0 mal in 0 Beiträgen
    positiv bewertet.
    Damit kenn ich mich nicht aus. Aber wäre Bootcamp und Windows keine Option?

  3. #3
    Community Administrator Avatar von Dotox
    Registriert seit
    18.10.2011
    Beiträge
    2.607
    Mag ich
    314
    Wurde 6.581 mal in 870 Beiträgen
    positiv bewertet.
    Wenn du den OSX Client bei uns geladen hast, musst du noch einen Patch installieren.

    Links sind nur für Mitglieder sichtbar

  4. Der folgende Benutzer mag diesen Beitrag:

    Sabbaer (21.12.2015)

  5. #4
    Neuling Avatar von DeNico
    Registriert seit
    21.11.2015
    Beiträge
    2
    Mag ich
    0
    Wurde 0 mal in 0 Beiträgen
    positiv bewertet.
    Vielen Dank für die Antworten.
    Nein Windows ist keine Alternative für mich.
    Den Patch habe ich runtergeladen und beide Dateien in den hauptordner des Spiels gezocken. wenn ich wow classic ausführe dann versucht er zu starten aber es kommt dieselbe Fehlermeldung wie bei dem anderen client (wurde unerwartet beendet). Muss ich das irgendwie anders installieren? also vorher etwas gesondert ausführen?

  6. #5
    Neuling Avatar von waldy
    Registriert seit
    29.11.2015
    Beiträge
    1
    Mag ich
    0
    Wurde 0 mal in 0 Beiträgen
    positiv bewertet.
    Ich befürchte, du kommst nicht drum herum, den umweg über bootcamp zu machen. Ich stand vor genau dem gleichen problem.
    Seit OSX Lion gibt es die rosetta-unterstützung nicht mehr. Das heisst: alter PPC-code wird nicht mehr ausgeführt. Wow classic setzt aber noch auf PPC-code auf.
    Somit befindest du dich nun in einer sackgasse und bootcamp ist dein freund.

    Sollte es einen funktionierenden ausweg geben würde ich mich auch sehr freuen, bis dahin starte ich um wow-classic spielen zu können ein win10

  7. #6
    Neuling Avatar von lekkerwurst
    Registriert seit
    12.04.2015
    Beiträge
    1
    Mag ich
    0
    Wurde 0 mal in 0 Beiträgen
    positiv bewertet.
    Funktioniert bei mir ohne Probleme, client für mac runtergeladen, mac patch drüber, dann ging es sofort.

  8. #7
    Neuling Avatar von Jakobol
    Registriert seit
    16.04.2016
    Beiträge
    1
    Mag ich
    0
    Wurde 0 mal in 0 Beiträgen
    positiv bewertet.
    Was muss ich denn genau mit dem Patch machen.. Wo muss ich den ablegen. Wie hast du es gemacht lekkerwurst.

  9. #8
    Neuling Avatar von Magie
    Registriert seit
    25.04.2016
    Beiträge
    2
    Mag ich
    1
    Wurde 0 mal in 0 Beiträgen
    positiv bewertet.
    Bei mir klappt es jetzt anscheinend doch, mein Ingame-Account war nicht registriert, weil ich ein ungültiges Passwort ausgesucht hatte und die Meldung übersehen habe!

    Ich bin gespannt!
    Aktualisiert von Magie (25.04.2016 um 23:13 Uhr)

  10. #9
    Neuling Avatar von Forturama
    Registriert seit
    15.05.2016
    Beiträge
    6
    Mag ich
    3
    Wurde 0 mal in 0 Beiträgen
    positiv bewertet.
    Wie genau installiere ich den OSX Client? Bekomme das irgendwie nicht hin.



    Edit: Habt geschafft. Einfach die exe in den WoW Ordner kopieren.
    Aktualisiert von Forturama (21.05.2016 um 04:44 Uhr)

  11. #10
    Neuling Avatar von AiwisOne
    Registriert seit
    29.06.2016
    Beiträge
    1
    Mag ich
    0
    Wurde 0 mal in 0 Beiträgen
    positiv bewertet.
    Ich glaube ich stelle mich zu glatt an.

    Ich habe auf meinem MacBook OSX 10.11.5, habe den Classic WoW Mac Client 1.12.1 von hier gezogen + Mac Patch.
    Client auf dem Mac mit UnRar Unarchiver (v 1.1) entpackt und danach die beiden Dateien vom Patch in den root vom Spiel kopiert. Nach dem starten der WoW Classic App kommt die Fehlermeldung das die Anwendung unerwartet geschlossen wurde.

    Hat einer eine Idee was ich falsch mache?

    LÖSUNG: Der Fehler lag am fehlerhaften entpacken. Ich habe es nun mit UnRarX entpackt und auch erst 187 Fehler beim entpacken gehabt. Nachdem ich ihm das Passwort zum entpacken gegeben habe, lief alles ohne Fehler. Nur noch Patch drüber und schon lief es :-)
    Aktualisiert von AiwisOne (30.06.2016 um 14:54 Uhr)

  12. #11
    Neuling Avatar von Superflu
    Registriert seit
    16.01.2015
    Beiträge
    2
    Mag ich
    0
    Wurde 0 mal in 0 Beiträgen
    positiv bewertet.
    Huhu habe das selbe Problem, habe mir gestern WoW classic für den Mac geladen. Wollte es jz öffnen und es kommt die Fehlermeldung. Habe jz den Patch gedownloadet und ihn in den Ordner gezogen ( World of Warcraft Kopie und World of Warcraft Classic) hab jz versucht beide zu öffnen aber funktioniert einfach nicht. Hab das Macbook noch nicht lange und kenn mich nicht ganz so gut aus. Kann mir vilt irgendwer helfen ? quasi eine step by step Anleitung

  13. #12
    Neuling Avatar von berndLauert
    Registriert seit
    03.01.2017
    Beiträge
    2
    Mag ich
    0
    Wurde 0 mal in 0 Beiträgen
    positiv bewertet.
    Hallo zusammen,

    hat hier zufällig jemand WoW auf macOS Sierra am laufen? Hab mir den Client gestern runtergeladen und den Patch drüber gelegt, bekomme beim Starten jedoch einen schwarzen Bildschirm der auch bleibt bis ich das Ganze per Cmd+Alt+Esc abwürge. Hat jemand zufällig eine Idee?

    Viele Grüße & Vielen Dank

  14. #13
    Neuling Avatar von Keldorax
    Registriert seit
    30.08.2015
    Beiträge
    3
    Mag ich
    0
    Wurde 0 mal in 0 Beiträgen
    positiv bewertet.
    Zitat Zitat von berndLauert Beitrag anzeigen
    Hallo zusammen,

    hat hier zufällig jemand WoW auf macOS Sierra am laufen? Hab mir den Client gestern runtergeladen und den Patch drüber gelegt, bekomme beim Starten jedoch einen schwarzen Bildschirm der auch bleibt bis ich das Ganze per Cmd+Alt+Esc abwürge. Hat jemand zufällig eine Idee?

    Viele Grüße & Vielen Dank
    Hi!
    Eine Lösung hab ich zwar nicht, ich kann dir aber definitiv bestätigen, dass es läuft. Ich hab mir das aktuelle (Ende 2016) MacBook Pro gekauft, MacOS Sierra auf dem aktuellsten Patchstand und kann ohne Probleme mit dem Mac Client spielen. Vielleicht hilft es, wenn du vor dem Start mal die config.wtf löschst.

    Wobei ich dir allerdings grundsätzlich anraten würde zum Spielen über ne parallele Windows Installation per Bootcamp nachzudenken, denn der Windows Client läuft wirklich um Welten performanter (fast die 2-3 fache Framerate).

  15. #14
    Neuling Avatar von berndLauert
    Registriert seit
    03.01.2017
    Beiträge
    2
    Mag ich
    0
    Wurde 0 mal in 0 Beiträgen
    positiv bewertet.
    Zitat Zitat von Keldorax Beitrag anzeigen
    Hi!
    Eine Lösung hab ich zwar nicht, ich kann dir aber definitiv bestätigen, dass es läuft. Ich hab mir das aktuelle (Ende 2016) MacBook Pro gekauft, MacOS Sierra auf dem aktuellsten Patchstand und kann ohne Probleme mit dem Mac Client spielen. Vielleicht hilft es, wenn du vor dem Start mal die config.wtf löschst.

    Wobei ich dir allerdings grundsätzlich anraten würde zum Spielen über ne parallele Windows Installation per Bootcamp nachzudenken, denn der Windows Client läuft wirklich um Welten performanter (fast die 2-3 fache Framerate).
    Hast du das 13 oder 15 Zoll Gerät? Ich hab auch ein Ende 2016 Macbook Pro (13 Zoll). Falls du 15 hast, könnte es bei mir an der Onboard-Grafikkarte liegen. Bootcamp ist eine Option, wollte mir dafür sowieso eine externe SSD anschaffen, auf die Windows & alles an Spielen drauf kommt (hab intern nur 256 GB).

    Hab jetzt mal testweise die Windows Version mit Wine unter macOS emuliert gestartet, das schaut ganz vernünftig aus, zumindest solange bis ich das über Bootcamp regle

  16. #15
    Neuling Avatar von balso
    Registriert seit
    10.08.2015
    Beiträge
    32
    Mag ich
    1
    Wurde 17 mal in 10 Beiträgen
    positiv bewertet.
    Es läuft auch auf einem Late2016 mit F-Key fehlerfrei. Ich hatte nur das Problem dass ich den Launcher entpacken und das Script per Hand starten musste.

Seite 1 von 2 12 LetzteLetzte

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)